Saturday, December 16, 2006

VNC server on Mac classic (8.6)

Similarly, like in the former post I would like to work from my Mac X Tiger, Linux, Solaris, Windows or any other system that I use at work, on my old Mac OS 8.6.
I decided to try to install VNC server on Mac classic and try how it goes.

I installed chromivnc server 3.40a5. The only thing after the installation, or rather I should say unpacking, was to copy vncPatches file to Systems Folder/Extensions and restart my mac. Afterwards, I started vnc server without any problems, and that was it. My vnc server on Mac 8.6 was working.

Nevertheless, I have to admit, that it is considerably slower with comparisons to more newer version of vnc for Mac X, or Linux. However, it is enough for fast, small work on Mac OS 8.6.

Below image showing Kubuntu with VNC connection to Mac X Tiger and Mac OS 8.6

Friday, December 15, 2006

VNC client on Mac classic (8.6)

Sometimes in my work I had to use Mac OS 8.6. Problem with this is, that this is very old operating system, and there are not new application on it. Most importantly the problem is with web browser. There are only Internet Explorer 5.0, Mozilla 1.3, and few other very, very old ones; thus, when I work on Mac 8.6 and want to use the Internet there is problem, because many web-pages don't work on such old browsers (e.g. google spreadshead). Of course, other programs like Matlab or GIMP are unavailable on Mac classic. This was of course very annoying me, because when I was using 8.6 I could not do other my work, because of lack of software.
Finally, recently I found solution. It is simply installing VNC server on my Mac X 10.4 and installing VNC client on Mac 8.6 and using this client to work on Tiger, while being on Classic.
Nonetheless, finding and starting VNC client on Mac Classic was not so simple. After some searching and reading I found what I was looking for, and I would like to shear with it. Hopefully it will be useful for someone :-)

VNC client on Mac Classic is VNCThing 2.2 to download e.g. from here.

Morever, to run this client it is necessary to have
CarbonLib 1.6 from here.

After installation of those programs I could enjoy my Mac X 10.4 from Mac 8.6.

Below to screen showing Mac 8.6 with VNC client connected to Mac X Tiger.

Tuesday, December 05, 2006

Ruby: Using DarwinPorts' Ruby instead of Mac X's

If you are familiar with Mac X, probably you heard about DarwinPorts ("The DarwinPorts Project's main goal is to provide an easy way to install various open-source software products"). If you are interested in Ruby, you probably know that Mac X Tiger comes with pre-installed Ruby 1.8.2. Nevertheless, using DrawinPorts you can install more newer version of Ruby (1.8.4) just by writing: sudo port install ruby .

Unfortunately after the installation you will have two Ruby's in your systems, and your xterm console by default will use the first one. In order to use second one, the PATH environmental variable must be slightly change i.e. putting directory /opt/local/bin (DarwinPorts default directory) before every other directory in PATH. As a results programs in /opt/local/bin will have priority over the other programs.

To change the path you can execute just:
export PATH=/opt/local/bin:$PATH